Not resolved
2 comments

Purchased swagtron envy red. Just 5-6 months old, probably total 5 hrs of ride time.

After charging scooter, notice throttle not working correctly, looking at troubleshooting guide, i have error code 007 (motor). So. I call tech support asked if this was common issue, tech replies "no", what? If its not common why is there an error code for it.

Anyway, got rma #, i have to pay the freight charges to ship it back to Indiana for warranty work? Frigging freight i had to pay was half the amount i paid for the scooter. Come on swagtron, i am customer.

Reimburse the freight cost, why not have 3rd party to fix issue instead of shipping back to you? Eagerly awaiting to hear your reply.

Ib.thrax@gmail.com

Do You Have Something To Say ?
Write a review

Comments

Terms of Service
Post Comment
Cancel
Swagway
#1555163

We are very sorry for any inconvenience this may have caused! Swagtron is happy to provide a pre-paid UPS label for all warranty repairs upon request!

Please email us at WeCare@Swagtron.com with your order information so that we can get this taken care of for you!

Customer support is standing by to assist and looks forward to hearing from you soon! #SwagtronCares

Anonymous
to Swagway #1555505

Thank you for replying. When I got rma #, someone should have asked or at least provided pre-paid label since was warranty work.

Envy is already in transist to Indiana.

I will email at wecare@swagtron.com to rectify or try to come to some resolution. Again, thank you for quick response.

You May Also Like